package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$_(GET|POST|REQUEST)\[[^\]]*\]`)
var str = `<?php
// before
$firstname = $_GET['firstname'];
$lastname = $_POST['lastname'];
$age = $_REQUEST['age'];
?>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}