import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?:https?|ftp):\\/\\/[^\\]\\[]+\\]\\([^()]*\\)|((?:https?|ftp):\\/\\/\\S+)";
final String string = "Login in to My site [https://example.com/](https://example.com/) and select Something > Select below details further.\n\n"
+ "Also have a look at https://example.com/abc/1.html";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}