import re
regex = re.compile(r"\[(?:https?|ftp):\/\/[^\]\[]+\]\([^()]*\)|((?:https?|ftp):\/\/\S+)", flags=re.IGNORECASE)
test_str = ("Login in to My site [https://example.com/](https://example.com/) and select Something > Select below details further.\n\n"
"Also have a look at https://example.com/abc/1.html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")