const regex = /\[(?:https?|ftp):\/\/[^\]\[]+\]\([^()]*\)|((?:https?|ftp):\/\/\S+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?:https?|ftp):\\\/\\\/[^\\]\\[]+\\]\\([^()]*\\)|((?:https?|ftp):\\\/\\\/\\S+)', 'gi')
const str = `Login in to My site [https://example.com/](https://example.com/) and select Something > Select below details further.
Also have a look at https://example.com/abc/1.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}