re = /\[(?:https?|ftp):\/\/[^\]\[]+\]\([^()]*\)|((?:https?|ftp):\/\/\S+)/i
str = 'Login in to My site [https://example.com/](https://example.com/) and select Something > Select below details further.
Also have a look at https://example.com/abc/1.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end