using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<match_1>chest|test|west|nest)(?: +(?P<match_2>mike|bike|like|pike)(?: +(?P<match_3>hay|day|may|say))?)?";
string input = @"zzz zzz zz chest bike day zzzz z test mike zzz zzzz west zzz zz
aaa aa aaa a nest aa aaaa aaa nest bike may aaaa aaa
ggg gg ggg ggg ggg test like hay ggg gg west ggg gggg west like ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}