import Foundation
let pattern = #"(?P<match_1>chest|test|west|nest)(?: +(?P<match_2>mike|bike|like|pike)(?: +(?P<match_3>hay|day|may|say))?)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
zzz zzz zz chest bike day zzzz z test mike zzz zzzz west zzz zz
aaa aa aaa a nest aa aaaa aaa nest bike may aaaa aaa
ggg gg ggg ggg ggg test like hay ggg gg west ggg gggg west like
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)