re = /(?P<match_1>chest|test|west|nest)(?: +(?P<match_2>mike|bike|like|pike)(?: +(?P<match_3>hay|day|may|say))?)?/m
str = 'zzz zzz zz chest bike day zzzz z test mike zzz zzzz west zzz zz
aaa aa aaa a nest aa aaaa aaa nest bike may aaaa aaa
ggg gg ggg ggg ggg test like hay ggg gg west ggg gggg west like '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end