import re
regex = re.compile(r"(?P<match_1>chest|test|west|nest)(?: +(?P<match_2>mike|bike|like|pike)(?: +(?P<match_3>hay|day|may|say))?)?", flags=re.MULTILINE)
test_str = ("zzz zzz zz chest bike day zzzz z test mike zzz zzzz west zzz zz\n"
"aaa aa aaa a nest aa aaaa aaa nest bike may aaaa aaa\n"
"ggg gg ggg ggg ggg test like hay ggg gg west ggg gggg west like ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")