#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b(?!(?:LV|and|normal|(?<=\bno\s+)cardiac|indexed|heart)\b)\w+\s+mass\b"
Local $sString = "There is a 2mm mass in the RA" & @CRLF & _
"large irregular mass in the left ventricle" & @CRLF & _
"" & @CRLF & _
"LV mass: 135g" & @CRLF & _
"Normal heart mass" & @CRLF & _
"" & @CRLF & _
"fact that cardiac mass is valid but no cardiac mass is invalid."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")