# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?!(?:LV|and|normal|(?<=\bno\s+)cardiac|indexed|heart)\b)\w+\s+mass\b"
test_str = ("There is a 2mm mass in the RA\n"
"large irregular mass in the left ventricle\n\n"
"LV mass: 135g\n"
"Normal heart mass\n\n"
"fact that cardiac mass is valid but no cardiac mass is invalid.")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.