import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!(?:LV|and|normal|(?<=\\bno\\s+)cardiac|indexed|heart)\\b)\\w+\\s+mass\\b";
final String string = "There is a 2mm mass in the RA\n"
+ "large irregular mass in the left ventricle\n\n"
+ "LV mass: 135g\n"
+ "Normal heart mass\n\n"
+ "fact that cardiac mass is valid but no cardiac mass is invalid.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}