const regex = /\b(?!(?:LV|and|normal|(?<=\bno\s+)cardiac|indexed|heart)\b)\w+\s+mass\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(?:LV|and|normal|(?<=\\bno\\s+)cardiac|indexed|heart)\\b)\\w+\\s+mass\\b', 'gmi')
const str = `There is a 2mm mass in the RA
large irregular mass in the left ventricle
LV mass: 135g
Normal heart mass
fact that cardiac mass is valid but no cardiac mass is invalid.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}