re = /\b(?!(?:LV|and|normal|(?<=\bno\s+)cardiac|indexed|heart)\b)\w+\s+mass\b/mi
str = 'There is a 2mm mass in the RA
large irregular mass in the left ventricle
LV mass: 135g
Normal heart mass
fact that cardiac mass is valid but no cardiac mass is invalid.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end