#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<\w+[^>]*?>((?R)|[^<]+)*<\/\w+>"
Local $sString = "<div>" & @CRLF & _
" div text" & @CRLF & _
" <div>div text</div>" & @CRLF & _
"</div>" & @CRLF & _
"outer text 1" & @CRLF & _
"<p>p text</ul>" & @CRLF & _
"outer text 2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")