using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\w+[^>]*?>((?R)|[^<]+)*<\/\w+>";
string input = @"<div>
div text
<div>div text</div>
</div>
outer text 1
<p>p text</ul>
outer text 2
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}