$re = '/<\w+[^>]*?>((?R)|[^<]+)*<\/\w+>/s';
$str = '<div>
div text
<div>div text</div>
</div>
outer text 1
<p>p text</ul>
outer text 2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);