// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<\w+[^>]*?>((?R)|[^<]+)*<\/\w+>").unwrap();
let string = "<div>
div text
<div>div text</div>
</div>
outer text 1
<p>p text</ul>
outer text 2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}