re = /<\w+[^>]*?>((?R)|[^<]+)*<\/\w+>/
str = '<div>
div text
<div>div text</div>
</div>
outer text 1
<p>p text</ul>
outer text 2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end