using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=foo)\d*(?=.*(?:\R(?!foo\d).*)*bar)";
string input = @"foo1
some text
foo12
some text
bar
some text
foo123
some text
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}