re = /(?<=foo)\d*(?=.*(?:\R(?!foo\d).*)*bar)/
str = 'foo1
some text
foo12
some text
bar
some text
foo123
some text
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end