import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=foo)\\d*(?=.*(?:\\R(?!foo\\d).*)*bar)";
final String string = "foo1\n"
+ "some text\n"
+ "foo12\n"
+ "some text\n"
+ "bar\n"
+ "some text\n"
+ "foo123\n"
+ "some text\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}