$re = '/(?<=foo)\d*(?=.*(?:\R(?!foo\d).*)*bar)/';
$str = 'foo1
some text
foo12
some text
bar
some text
foo123
some text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);