#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[.!?])[^.!?]*:\s*$"
Local $sString = "Trump met with Putin. Learn more here:" & @CRLF & _
"New movie by Christopher Nolan! Watch here:" & @CRLF & _
"Campers: Get ready to stop COVID-19 in its tracks!" & @CRLF & _
"London was building a bigger rival to the Eiffel Tower. Then it all went wrong." & @CRLF & _
"I don't want to do a national lockdown again. If #coronavirus continues to 'progress' in the UK. Read more here:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")