import Foundation
let pattern = #"(?<=[.!?])[^.!?]*:\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Trump met with Putin. Learn more here:
New movie by Christopher Nolan! Watch here:
Campers: Get ready to stop COVID-19 in its tracks!
London was building a bigger rival to the Eiffel Tower. Then it all went wrong.
I don't want to do a national lockdown again. If #coronavirus continues to 'progress' in the UK. Read more here:
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)