const regex = /(?<=[.!?])[^.!?]*:\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[.!?])[^.!?]*:\\s*$', 'gm')
const str = `Trump met with Putin. Learn more here:
New movie by Christopher Nolan! Watch here:
Campers: Get ready to stop COVID-19 in its tracks!
London was building a bigger rival to the Eiffel Tower. Then it all went wrong.
I don't want to do a national lockdown again. If #coronavirus continues to 'progress' in the UK. Read more here:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}