using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[.!?])[^.!?]*:\s*$";
string input = @"Trump met with Putin. Learn more here:
New movie by Christopher Nolan! Watch here:
Campers: Get ready to stop COVID-19 in its tracks!
London was building a bigger rival to the Eiffel Tower. Then it all went wrong.
I don't want to do a national lockdown again. If #coronavirus continues to 'progress' in the UK. Read more here:";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}