$re = '/(?<=[.!?])[^.!?]*:\s*$/m';
$str = 'Trump met with Putin. Learn more here:
New movie by Christopher Nolan! Watch here:
Campers: Get ready to stop COVID-19 in its tracks!
London was building a bigger rival to the Eiffel Tower. Then it all went wrong.
I don\'t want to do a national lockdown again. If #coronavirus continues to \'progress\' in the UK. Read more here:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);