$re = '~(https?://)|(/)+~';
$str = 'http://127.0.0.1:7000//test//test//index.html';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;