import re
regex = re.compile(r"(https?://)|(/)+")
test_str = "http://127.0.0.1:7000//test//test//index.html"
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)