import Foundation
let pattern = #"(https?://)|(/)+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://127.0.0.1:7000//test//test//index.html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)