using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!:)\/\/+";
string substitution = @"/";
string input = @"http://127.0.0.1:7000//test//test//index.html";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}