re = /(?<!:)\/\/+/
str = 'http://127.0.0.1:7000//test//test//index.html'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result