use strict;
my $str = 'http://127.0.0.1:7000//test//test//index.html';
my $regex = qr/(?<!:)\/\/+/p;
my $subst = '/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";