$re = '/(?<!:)\/\/+/';
$str = 'http://127.0.0.1:7000//test//test//index.html';
$subst = "/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;