const regex = /(?<!:)\/\/+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!:)\\\/\\\/+', 'g')
const str = `http://127.0.0.1:7000//test//test//index.html`;
const subst = `/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);