#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^\s@])([^\s@]*)@([^\s@])([^\s@]*)(\.[^\s.@]+)"
Local $sString = "exampleEmail@example.com" & @CRLF & _
"a@e.co.uk" & @CRLF & _
"ab@ab.co.uk" & @CRLF & _
"test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")