package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\s@])([^\s@]*)@([^\s@])([^\s@]*)(\.[^\s.@]+)`)
var str = `exampleEmail@example.com
a@e.co.uk
ab@ab.co.uk
test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}