re = /([^\s@])([^\s@]*)@([^\s@])([^\s@]*)(\.[^\s.@]+)/m
str = 'exampleEmail@example.com
a@e.co.uk
ab@ab.co.uk
test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end