using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s@])([^\s@]*)@([^\s@])([^\s@]*)(\.[^\s.@]+)";
string input = @"exampleEmail@example.com
a@e.co.uk
ab@ab.co.uk
test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}