$re = '/([^\s@])([^\s@]*)@([^\s@])([^\s@]*)(\.[^\s.@]+)/m';
$str = 'exampleEmail@example.com
a@e.co.uk
ab@ab.co.uk
test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);