const regex = /\((.*)\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((.*)\\)', 'g')
const str = `1. ('1KtxNawkosV1H5jzUzW_\$1'),#38,'2ndLevel', '2a',#251524,#251773,#328411,.PHYSICAL.,.EXTERNAL.
2. '1KtxNawkosV1H5jzUzW_\$1',#38,'2ndLevel', '2a',#251524,#251773,(#328411,.PHYSICAL.,.EXTERNAL.)
3. ('1KtxNawkos(asd)V1H5jzU)zW_\$1', ('asd', #23331), #21)<-- ###should end here###,#38,'2ndLevel', '2a',#251524,#251773,#328411,.PHYSIaCAL.,.EXTERNAL., ')'
4. #38,'2ndLevel',('1KtxNawkos(asd)V1H5jzU)zW_\$1') '2a',#251524,#251773,#328411,.PHYSICAL.,.EXTERNAL.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}