import Foundation
let pattern = #"\((.*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ####"""
1. ('1KtxNawkosV1H5jzUzW_$1'),#38,'2ndLevel', '2a',#251524,#251773,#328411,.PHYSICAL.,.EXTERNAL.
2. '1KtxNawkosV1H5jzUzW_$1',#38,'2ndLevel', '2a',#251524,#251773,(#328411,.PHYSICAL.,.EXTERNAL.)
3. ('1KtxNawkos(asd)V1H5jzU)zW_$1', ('asd', #23331), #21)<-- ###should end here###,#38,'2ndLevel', '2a',#251524,#251773,#328411,.PHYSIaCAL.,.EXTERNAL., ')'
4. #38,'2ndLevel',('1KtxNawkos(asd)V1H5jzU)zW_$1') '2a',#251524,#251773,#328411,.PHYSICAL.,.EXTERNAL.
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)