use strict;
my $str = '1. (\'1KtxNawkosV1H5jzUzW_$1\'),#38,\'2ndLevel\', \'2a\',#251524,#251773,#328411,.PHYSICAL.,.EXTERNAL.
2. \'1KtxNawkosV1H5jzUzW_$1\',#38,\'2ndLevel\', \'2a\',#251524,#251773,(#328411,.PHYSICAL.,.EXTERNAL.)
3. (\'1KtxNawkos(asd)V1H5jzU)zW_$1\', (\'asd\', #23331), #21)<-- ###should end here###,#38,\'2ndLevel\', \'2a\',#251524,#251773,#328411,.PHYSIaCAL.,.EXTERNAL., \')\'
4. #38,\'2ndLevel\',(\'1KtxNawkos(asd)V1H5jzU)zW_$1\') \'2a\',#251524,#251773,#328411,.PHYSICAL.,.EXTERNAL.
';
my $regex = qr/\((.*)\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}