# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\((.*)\)"
test_str = ("1. ('1KtxNawkosV1H5jzUzW_$1'),#38,'2ndLevel', '2a',#251524,#251773,#328411,.PHYSICAL.,.EXTERNAL.\n\n"
"2. '1KtxNawkosV1H5jzUzW_$1',#38,'2ndLevel', '2a',#251524,#251773,(#328411,.PHYSICAL.,.EXTERNAL.)\n\n"
"3. ('1KtxNawkos(asd)V1H5jzU)zW_$1', ('asd', #23331), #21)<-- ###should end here###,#38,'2ndLevel', '2a',#251524,#251773,#328411,.PHYSIaCAL.,.EXTERNAL., ')'\n\n"
"4. #38,'2ndLevel',('1KtxNawkos(asd)V1H5jzU)zW_$1') '2a',#251524,#251773,#328411,.PHYSICAL.,.EXTERNAL.\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.