re = /\((.*)\)/
str = '1. (\'1KtxNawkosV1H5jzUzW_$1\'),#38,\'2ndLevel\', \'2a\',#251524,#251773,#328411,.PHYSICAL.,.EXTERNAL.
2. \'1KtxNawkosV1H5jzUzW_$1\',#38,\'2ndLevel\', \'2a\',#251524,#251773,(#328411,.PHYSICAL.,.EXTERNAL.)
3. (\'1KtxNawkos(asd)V1H5jzU)zW_$1\', (\'asd\', #23331), #21)<-- ###should end here###,#38,\'2ndLevel\', \'2a\',#251524,#251773,#328411,.PHYSIaCAL.,.EXTERNAL., \')\'
4. #38,\'2ndLevel\',(\'1KtxNawkos(asd)V1H5jzU)zW_$1\') \'2a\',#251524,#251773,#328411,.PHYSICAL.,.EXTERNAL.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end