import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<code_1>\\d+-\\d+)(?:\\s*,\\s*(?P<code_2>\\d+-\\d+))?(?:\\s*,\\s*(?P<code_3>\\d+-\\d+))?$";
final String string = "21-1091, 21-1094, 21-1099";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}