const regex = /^(?P<code_1>\d+-\d+)(?:\s*,\s*(?P<code_2>\d+-\d+))?(?:\s*,\s*(?P<code_3>\d+-\d+))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<code_1>\\d+-\\d+)(?:\\s*,\\s*(?P<code_2>\\d+-\\d+))?(?:\\s*,\\s*(?P<code_3>\\d+-\\d+))?$', 'gm')
const str = `21-1091, 21-1094, 21-1099`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}