re = /^(?P<code_1>\d+-\d+)(?:\s*,\s*(?P<code_2>\d+-\d+))?(?:\s*,\s*(?P<code_3>\d+-\d+))?$/m
str = '21-1091, 21-1094, 21-1099'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end