$re = '/^(?P<code_1>\d+-\d+)(?:\s*,\s*(?P<code_2>\d+-\d+))?(?:\s*,\s*(?P<code_3>\d+-\d+))?$/m';
$str = '21-1091, 21-1094, 21-1099';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);